Website banner showing no image

February 25, Tue
Affected Service: Main Website
  • Investigating Problems
    The website banner does not properly show the uploaded image. We're currently working on this minor issue.

    09:13, Jan 08 CEST
  • Resolved
    Banner has been disabled.

    18:10, Feb 25 CEST
Back to current status